我们不断改进每一处的细微体验

共迭代 21 个系统版本, 328 个软件版本, 优化 367 处功能与错误
  • 深度系统更新(2017.10.19)

    • 将debconf配置为图形用户界面,来支持控制中心和商店在某些情况下需要交互的问题;
    • 更新打印机驱动程序;
    • 深度录屏更新到 2.6.1版本,修复录制的mp4无法在手机视频播放器以及微信等app中播放的问题;
    • 修复百度网盘更新后无法启动的问题。
  • 深度终端V2.7发布

    • 新增主题终端功能,Ctrl + Alt + 数字1~9打开9种不同的主题颜色的终端,通过配置文件的theme_terminal选项来设置;
    • 新增 run_as_login_shell 的选项(默认禁用),通过配置文件中默认打开Login Shell的功能;
    • 新增git vte 库来实现终端控件功能,修复了因为 vte 引起的不能向上搜索的问题
    • 优化当传入终端预设命令行选项时,终端不再报“未知选项”的命令行提示去干扰用户;
    • 优化终端滚动条,避免VTE和Gtk.ScrolledWindow冲突导致极限编译时切换标签会导致终端直接崩溃的问题;
    • 优化在多屏幕的工作环境中,雷神窗口可以根据当前屏幕的大小自动调整终端窗口宽度;
    • 修复 emoji 表情导致的终端卡死的问题;
  • 深度安全更新——无线WIFI严重漏洞WPA2(DSA 3999-1)紧急修复

    • 有安全研究人员发布他们在 WPA2 加密协议上发现了多起漏洞,利用这些漏洞的攻击者可能会迫使弱势系统重新使用加密会话密钥,从而对WPA1和WPA2中使用的密码进行一系列加密攻击。
    • 研究人员透过这些漏洞的组合,发布了一个概念验证攻击 KRACK(代表 Key Reinstallation Attacks),并在 Github 设立了一个 入口 ,并建立了一个网站 krackattacks.com。
    • WPA全称为Wi-Fi Protected Access,有WPA和WPA2两个标准,是一种保护无线网络安全的加密协议。WPA2 加密协议在 Wi-Fi 网络中的作用,是让资料封包在无线网络传送的时候,透过加密让其他人就算是拦截了封包,因为无法解密也无法解析读到里面的资料。因此,如果 WPA2 加密协议真的被破解的话,这就表示任何人只要在你的 Wi-Fi 覆盖范围,都可以知道你现在在网络上进行的活动,甚至是你与其他人 LINE、FB 上传的讯息,你在网站上输入了什么内容。
    • 美国国土安全部(Department of Homeland Security)旗下的美国电脑紧急应变小组(US-CERT)表示:
    • 近期发现了多项 WPA2 安全认证的关键管理漏洞,KRACK 的影响内容包含解密、封包重送、TCP 连结绑架、HTTP 内容注入等等。值得注意的地方是,由于这是一起安全协议等级的事件,大部分的安全标准都将有可能被影响。CERT/CC 以及研究人员 KU Leuven 将会在今天稍晚推出 KRACK 事件的详细内容。
    • 如果 KRACK 的安全漏洞确实存在的话,现行的安全标准无法马上更新,有些甚至可能根本不会更新,因此,这次发现的漏洞的潜在风险可能非常大。
    • 不过,由于有心人士可以读取的是透过 WPA2 加密的内容,如果你使用的通讯工具或是其它软件也有加密功能的话,还是可以确保资料的安全。比方说 LINE 在传讯的时候,也有进阶的加密模式,在这种情况下,黑客就算解开了 WPA2 的加密,依然无法读取你的内容。
    • 目前对于 KRACK 的资讯还不够,因此,还无法确定 Wi-Fi 网络被绑架或窃听的容易度,不过晚点 krackattacks.com 的研究人员应该就会提出更多相关内容,而正式的内容介绍则会在 11 月 1 日时于达拉斯举办的论坛议程: 《Key Reinstallation Attacks: Forcing Nonce Reuse in WPA2) 上公开。
  • 深度系统更新

    • Policykit更新,修复环境变量失效的问题;
    • 官方打包了企业微信,并修复企业微信不能最小化的问题;
    • 修复和更新了千牛工作台;
    • 深度商店上架和更新应用。
  • 深度操作系统常规更新

    • 合并debian上游更新以及修复部分Bug。
  • 深度系统更新(2017.09.29)

    • 控制中心changelog增加支持网址链接的特性。
  • 深度系统更新(2017.09.15)

    • 更新PulseAudio到10.0版本;
    • 深度安全更新修复蓝牙协议严重漏洞BlueBorne (CVE-2017-1000250);
    • Synaptics配置文件回退到上一版本,解决更新后部分特定机型触摸板无法正常使用问题;
    • 更新 Firefox、Chrome、Opera 对应Flash插件包到27.0.0.130版本。
  • 深度系统更新(2017.09.13)

    • 更新flatpak到0.9.7-1版本;
    • 修复flatpak导致sogou输入法图标显示不正确的问题;
    • 修复network-manager导致WiFi网络无法连接的问题;
    • 修复的深度看图翻译问题;
    • 修复阿里旺旺安装后提示过期,并无法更新的问题;
  • 深度系统更新(2017.09.08)

    • 更新Synaptics配置文件,解决触摸板指压和掌压问题,改善触摸板的使用体验;
    • 更新network-manager至最新1.8.2版本,具体更新日志请参考https://cgit.freedesktop.org/NetworkManager/NetworkManager/tree/NEWS?h=1.8.2;
    • 修复微信在桌面留有黑块的bug;
    • 深度终端更新到2.6版本,详情见https://www.deepin.org/2017/09/08/deepin-terminal-v2-6-0-is-released/。
  • 深度操作系统常规更新

    • 升级chrome版本到54
    • Chrome取消flash支持后,打包flash插件集成
    • 深度文件管理器V1.3发布
    • 修复社区用户和内测用户反馈的一些Bug
  • 深度操作系统常规更新

    • 修复控制中心更新概率性升级卡住的问题;
    • 修复内核升级导致硬件驱动不兼容导致无法进入系统;
    • 更新系统N卡闭源驱动到367;
    • 优化内核对Intel六代CPU的支持;
    • 修复了系统一些bug问题;
    • 深度商店更新或上架部分应用;
  • 深度操作系统常规更新

    • 修复了部分上游安全更新问题。
    • 修复了因内核引起的部分Bug。
    • 新增libtxc-dxtn-s2tc0依赖,解决Steam游戏运行时报错的问题。
    • 升级了Qt组件解决部分应用不能运行和闪退的问题。
    • 修复了输入部分字符导致不能输入中文的问题。
    • 优化并发布了深度看图1.1版本。
  • 深度操作系统 15.3

    • 全新深度终端2.0、深度看图及日历
    • 合并电源插件和关机按钮
    • 优化网络插件、声音插件、挂载插件等一系列插件组
    • 优化系统托盘管理
    • 修复显示模块,双屏模式切换偶尔失灵的问题
    • 修复显示模块,多次双屏切换后桌面内容位置不对等的问题;
    • 修复网络模块,新建用户登陆使用网络需要验证权限的问题;
    • 修复声音模块,声音播放无法手动切换到HDMI外接设备问题;
    • 修复日期和时间模块,偶尔无法添加时区问题;
    • 修复键盘和语言模块,键盘重复延迟设置重启后失效问题;
    • 修复启动菜单模块,系统安装后启动菜单分辨率很低的问题;
    • 修复keyring解锁对话框经常弹出的问题
    • 修复桌面文件偶尔无法选中和拖拽的问题
    • 修复第一次进入系统,新建模板不能使用问题
    • 修复系统重启后,桌面文件位置被重置的问题
    • 修复从启动器发送图标到桌面,图标无法识别的问题
    • 新增应用图标主题支持
    • 新增对Emacs风格导航快捷键支持
    • 优化分类文字显示动画
    • 修复低分辨率下显示不全的问题
    • 修复鼠标在空白处滚动无效的问题
    • 新增背景设置支持
    • 优化切换用户操作
    • 修复无法切换键盘布局的问题
    • 修复多用户显示不全的问题
    • 修复session很多时显示不全的问题
    • 修复下载/更新进度一直为0的问题
    • 修复自动检查更新功能没有保存的问题
    • 修复偶尔出现的系统更新后仍然提示有更新的问题