上次系统升级后 ,OpenGL的相关问题

noahsai
1. 问题/建议描述
问题:上次系统更新后,出现一下与OpenGL相关的问题,
①打开qtcreator提示加载插件错误,插件初始化失败: Cannot create OpenGL context.
②nvidia-setting里的 Opengl/glx information选项一点击程序就闪退。
③深度截图无法打开,终端输出
failed to acquire GL context to resolve capabilities, using defaults..Failed to create OpenGL context for format QSurfaceFormat(version 2.0, options QFlags(), depthBufferSize -1, redBufferSize -1, greenBufferSize -1, blueBufferSize -1, alphaBufferSize 8, stencilBufferSize -1, samples -1, swapBehavior 0, swapInterval 1, profile 0)
之前遇到过这问题,但是通过重装n卡驱动可以解决,这次发现不行。
无论是purge 了nvidia-legacy-304xx-driver 再重装,还是purge 了 nvidia* 再重装依然无法解决。
【另外】
①我发现上次升级后,qt的程序有点奇怪,自己写的挫b插件(图片右下角有箭头指的那个)发现背景颜色消失了,本来应该是深蓝色背景的。
至于旁边的字一大一小我就忘了是不是本来就这样。
还有就是底部的两个直角本来应该时圆角来的,升级后变成直角了,而且顶部的圆角好像比以前明显很多。。。
②qbittorrent 这次升级后无法退出程序,界面上点击了“退出”,任务栏里确实是没有了,但是用监视器可以看到程序依然存在,需要杀死后才能再次打开。
2. 问题如何重现
基本每次涉及到显卡驱动的升级都会出现该情况。
3. 版本说明
系统版本:15.3
应用版本:nvidia-legacy-304xx-driver is already the newest version (304.132-1).
内核版本:Linux sheng-pc 4.4.0-3-deepin-amd64 #1 SMP Deepin 4.4.30-2 (2016-12-01) x86_64 GNU/Linux

操作系统 :deepin
桌面环境 :others


处理中 | 系统配置(启动/仓库/驱动) 转至bugzilla
noahsai
现在安装了debian源里的304驱动之后暂时恢复正常使用。
nvidia-legacy-304xx-driver 304.134-0~deb8u1 amd64 NVIDIA metapackage (304xx legacy version)